JavaScript is disabled. For a better experience, please enable JavaScript in your browser before proceeding.

You are watching: 4l60e transmission shifts in and out of overdrive


*

*

I have a 2000 s10 with 2.2 auto and i just had the valve body repaired and now it works great except at highway speeds it will be running around 2200 rpms then go up (it wont go up quickly it will just slowly rise, takes about 5 seconds) to around 3200 rpms then it seems to bog back down to 2200 rpms, if i hit the throttle when the rpms rise it will shift and be fine and go back to 2200 rpms, any ideas would be greatly appreciated it seems to do this more with cruise control on because its at a constant speed and it never seems to do it going up hills, does it more going down hills or on flat but it seems to me it keeps shifting out of overdrive. I tried replacing the tps and had the fluid flushed.
Ext Cab, 1988 GMC S15 GypsyLime Green, 305ci, 700r4. Edelbrock 600CFM, TBI Serpentine Belt Setup, Performer Intake, Iroc-Z Wheels, 3.08 Open Rear, Slapper Bars, 3" Belltech drop leaves. 2" Ground Force Drop Spindles, B&M Mega Shifter, Forward Mounted 4.3 Rad. E-Fan, B&M Trans Cooler.Sitting in garage, waiting to install: Stereo, 700r4 Lockup Kit, E-brake Cables.Blew up the old 350, Now 305 needs a rebuild. What to do... LSx?
*

You can do a resistance check through the harness. I don"t have a pinout with me right now. If you have access to a scan tool, see if you can command the tcc solenoid on and off. Otherwise, drop the pan, pull the solenoid out, and replace it. You said you just had the valve body repaired. What repairs were done? How long ago? Did you get any sort of warranty on the labour? Was it like this before the repair?
Ext Cab, 1988 GMC S15 GypsyLime Green, 305ci, 700r4. Edelbrock 600CFM, TBI Serpentine Belt Setup, Performer Intake, Iroc-Z Wheels, 3.08 Open Rear, Slapper Bars, 3" Belltech drop leaves. 2" Ground Force Drop Spindles, B&M Mega Shifter, Forward Mounted 4.3 Rad. E-Fan, B&M Trans Cooler.Sitting in garage, waiting to install: Stereo, 700r4 Lockup Kit, E-brake Cables.Blew up the old 350, Now 305 needs a rebuild. What to do... LSx?
ya i just had the valve body reapaired about 3 or 4 weeks ago im not sure exactly what it was, he said he had to bore something out, I can check and see what it was for sure though, and i think it actually did this once a couple of months before that got repaired but when it happened then it wouldnt go in overdrive at all (or whatever was happening, i thought the transmission was slipping at the time cause it was revving up so high) but it never happened again until after the valve body got repaired. I"m not sure if it came with a warranty but its a very reputable transmission shop and im sure theyd stand behind their work.
ya i just had the valve body reapaired about 3 or 4 weeks ago im not sure exactly what it was, he said he had to bore something out, I can check and see what it was for sure though, and i think it actually did this once a couple of months before that got repaired but when it happened then it wouldnt go in overdrive at all (or whatever was happening, i thought the transmission was slipping at the time cause it was revving up so high) but it never happened again until after the valve body got repaired. I"m not sure if it came with a warranty but its a very reputable transmission shop and im sure theyd stand behind their work.
I"d take it back to them, and have them repair it. It should be at no cost to you. If they stand behind their work, then take it back to them. I know some shops give anywhere from a 3-6 month warranty on the labour. But at 3-4 weeks or so and you"re having similar issues, then I think its the shop"s responsibility.
Ext Cab, 1988 GMC S15 GypsyLime Green, 305ci, 700r4. Edelbrock 600CFM, TBI Serpentine Belt Setup, Performer Intake, Iroc-Z Wheels, 3.08 Open Rear, Slapper Bars, 3" Belltech drop leaves. 2" Ground Force Drop Spindles, B&M Mega Shifter, Forward Mounted 4.3 Rad. E-Fan, B&M Trans Cooler.Sitting in garage, waiting to install: Stereo, 700r4 Lockup Kit, E-brake Cables.Blew up the old 350, Now 305 needs a rebuild. What to do... LSx?
if they said they bored something out i"d guess they didn"t even mess with the TCC, I"d take it back to them and tell them to change it out
if they said they bored something out i"d guess they didn"t even mess with the TCC, I"d take it back to them and tell them to change it out
Chances are on what they "bored" was the torque converter clutch apply valve cylinder. Now Im assuming they reused your old TCC solenoid. Or they just bored, and didn"t do a proper re-sleeving of the cylinder. I"d still take it back, and tell them to check. Post your findings.
Ext Cab, 1988 GMC S15 GypsyLime Green, 305ci, 700r4. Edelbrock 600CFM, TBI Serpentine Belt Setup, Performer Intake, Iroc-Z Wheels, 3.08 Open Rear, Slapper Bars, 3" Belltech drop leaves. 2" Ground Force Drop Spindles, B&M Mega Shifter, Forward Mounted 4.3 Rad. E-Fan, B&M Trans Cooler.Sitting in garage, waiting to install: Stereo, 700r4 Lockup Kit, E-brake Cables.Blew up the old 350, Now 305 needs a rebuild. What to do... LSx?
ok so it was throwing the 1870 code and im pretty sure they bored and resleeved the tcc cylinder like you said, but didnt replace the solenoid, so im thinking the solenoid is my problem? also is this the correct solenoid i need? http://www.autozone.com/autozone/ca...earchText=&categoryDisplayName=&parentId=12-0thanks for all your help
replaced the solenoid and it still does the same thing, this is becoming a nightmare as the majority of my driving is on the highway, so the only thing i can think of now is torque converter? any help would be greatly appreciated
It"s funny how I am having the same problem on my girlfriends s-10 pickup. 4x2. It"s driving her and I nuts. I did a fluid/filter change, which it was really dirty. I am doing the research and haven"t tried a flush yet or the TCC solenoid yet. There is 137,000 miles on the truck. I just hope the trans isn"t going. It also seems like alot of people have had the same problem, but no one posted whether or not they fixed it. Would like to know what the fix would be.
ya mine also has 13X,XXX miles on it, I"m really hoping its the torque converter, I"ll be sure to post if it does.

See more: How Long After Taking Phentermine Can I Breastfeed Ing Your Child?


Have you tried to run a scanner on your truck? I got a code P1820.P1820 Transmission Transfer Case Clockwise Shift Relay Coil Circuit Failureor go here,http://www.usmam.org/forum/f105/obd-2-codes-296361/
I just recently got the code P1820 in my 99 S10. Can someone please inform me of ways to fix this? Or is the only way to replace the transmission. Searched the whole web to find something on this silly code but came up empty handed. Thanks.
anyone? I"m just about to buy a torque converter and would just like some inout if that could be what I need, thanks
well the torque converter didn"t fix the problem I guess i"m gonna have to take it into the shop unless anyone else has any ideas?
I tried changing the pwm solemoid as my last idea but didnt fix the problem, noone knows what this could be?
I tried changing the pwm solemoid as my last idea but didnt fix the problem, noone knows what this could be?
usmam.org is the community to discuss the S-Series, Chevrolet Colorado and GMC Canyon. Join to discuss rebuilds, modifications, tech articles and more!